Conversion Hero

Dicas para actualizar o seu blog para o novo WordPress 2.7 sem problemas!

O WordPress 2.7 foi lançado recentemente e pelo que tenho visto e lido em muitos blogs, existem uma série de blogueiros e autores que estão tendo dificuldades em fazer a migração para a nova plataforma, pelo que senti necessidade de produzir aqui no Fique-Rico um artigo completo com dicas para auxiliar os mais novos e também os mais experientes, a actualizarem a sua plataforma sem correrem riscos.

A verdade é que o WordPress 2.7 é uma das actualizações mais simples que alguma vez ocorreu no WordPress. Os problemas que surgem entretanto, estão na sua maioria associados a incompatibilidades de plugins e/ou a templates que fazem uso de secções de comentários customizadas, ou coisas do tipo.
Neste artigo pretendo colocar em cima da mesa os diversos passos que surgem aos vários tipos de utilizadores e autores que fazem uso da plataforma WordPress.

wp 2.7 actualizar

VERIFICAR COMPATIBILIDADE COM ALOJAMENTO/HOSPEDAGEM

Antes de actualizar o seu blog para a nova versão do WordPress 2.7, é importante verificar se o seu alojamento é compatível com as novidades e técnicas que a nova versão incorpora. Isso inclui código, scripts, livrarias e outros tipos de atributos técnicos que serão extremamente essenciais ao seu normal funcionamento. Poderá começar por visitar a página do Core Update Host Compatibility que se encontra na página da organização WordPress, e que inclui a informação que o seu provedor de serviço provavelmente irá necessitar.

Uma das novidades é que o WordPress 2.7 corre agora em PHP5, o que significa que é importante que o seu provedor de serviço actualize a sua conta tanto ao nível da versão do PHP como do MySQL.
Se por ventura o seu provedor não for compatível com a nova versão do WordPress, procure entrar em contacto com ele e descobrir se ele está disposto a actualizar o servidor. Se não estiver, procure recorrer a um novo provedor de serviço de alojamento/hospedagem.

ACTUALIZAR A PARTIR DE UMA VERSÃO ANTIGA

Na actualização manual de uma versão antiga para a nova versão do WordPress 2.7, recomenda-se que execute um processo manual passo-a-passo e sem riscos. Se tenciona actualizar o seu blog da versão 2.3 para a 2.7, é seguro que poderá sofrer algumas consequências com uma mudança tão brusca e descrepante. Se pretende fazer uma actualização de uma versão muito antiga, recomendamos que faça várias actualizações até chegar ao WordPress 2.6 e posteriormente ao WP2.7. Para isso irá necessitar dos seguintes documentos informativos:

Se por ventura utiliza plugins como o Auto Upgrade WordPress Plugin, o sticky post WordPress Plugin, ou o Admin Drop Down Menus WordPress Plugin, tenha em mente que todos eles já estão integrados na nova versão do WP2.7, pelo que aconselhamos que os desactive e elimine a partir do momento em que o upgrade estiver concluído.

como actualizar o wordpress

COMO ACTUALIZAR PARA O NOVO WORDPRESS 2.7?

Se por ventura já está a utilizar uma das versões beta que foram lançadas ao longo das últimas semanas, poderá simplesmente fazer a actualização através do sistema de actualizações automáticas já presente no novo WordPress 2.7. Se por ventura está a utilizar uma versão mais antiga, siga os seguintes passos:

MEDOS COMUNS DE ACTUALIZAR PARA O WORDPRESS 2.7

  • Actualização
    Muitos autores têm medo de actualizar o seu blog para a versão 2.7 pelo simples motivo de a considerarem dolorosa e complexa de fazer. Na verdade esta será a última vez que terá de fazer uma actualização complicada, uma vez que o novo WP2.7 passou a incluir um gestor de actualizações automáticas que actualiza o seu blog num ápice.
  • O Template vai quebrar
    Primeiro é necessário referir que o novo WP2.7 é totalmente retro-compatível com o código dos templates existentes, incluindo das secções de comentários. Se ele quebrar, é simplesmente porque um plugin não estava funcionando direito. Se por ventura o seu template faz uso de uma secção de comentários customizada, leia o guia de migração de plugins e temas para wp2.7 ou então aprenda a tornar os comentários do seu blog compatíveis com WP2.7.
  • Utilização de Plugins
    Muitos autores sentem que não poderão mais utilizar os seus plugins favoritos, sob pena de estes não serem compatíveis com o WordPress 2.7. A verdade é que poderá consultar a lista de plugins compatíveis com o WordPress 2.7. Se esta a actualizar o seu blog a partir de uma versão Beta, considere ler as instruções de actualização do WordPress, que referem a desactivação de todos os plugins antes da actualização.

COMO OBTER AJUDA COM O WORDPRESS 2.7?

Alguns dos problemas mais comuns com o WordPress 2.7, relatados no Fórum oficial do WordPress, estão praticamente e directamente relacionados com o seguinte:

  1. Admin Drop Down Menu WordPress Plugin: Este plugin já não é suportado no novo WordPress 2.7, uma vez que a nova dashboard já inclui esta opção de drop down. Desactive o plugin se não pretende criar conflictos com o seu Wp2.7.
  2. Internet Explorer torna o interface estranho: Os desenvolvedores do WordPress têm lutado com o browser Internet Explorer para o tornar compatível com o novo design. É recomendável que utilize para já o FireFox 3, Google Chrome, e Safari 3 se pretender uma experiência mais completa.
  3. WordPress Auto Upgrade Plugin: Este plugin já não é suportado no novo WordPress 2.7. Esta nova versão já inclui um actualizador automático integrado, pelo que deverá desactivar este plugin após a actualização do seu blog.
  4. Sticky Posts: Este plugin já não é suportado no novo WordPress 2.7. Desactive o plugin se não pretende criar conflictos com o seu Wp2.7.
  5. Impossibilidade de aceder aos plugins WordPress depois da actualização: O acesso aos Plugins WordPress agora é feito pelo Painel WordPress Dashboard. Se estiver com problema em encontrá-los, o link directo é o seguinte: http://exemplo.com/wp-admin/plugins.php.
  6. Um Plugin não funciona: Certifique-se de que lê primeiro a lista de plugins compatíveis com o WordPress 2.7 antes de começar a instalar e activar os seus plugins. 
mais ajuda com wordpress

OUTRO TIPO DE AJUDA

Tendo em conta que muitos utilizadores sentem necessidade de serem ajudados sempre que surge um problema no seu blog e/ou no seu dia-a-dia, recomendamos os seguintes locais para o ajudar com o seu blog WordPress:

 

Agora já não tem motivos para não actualizar o seu blog!

Até Já!


Se gostou deste post, considere subscrever o nosso RSS Feed Completo!
Ou então Subscreva o Fique Rico por Email!

Artigos
Relacionados

Comentários (20) Interações no Twitter (0)

Gostou desse artigo?

Partilhar Comentar

Tweetar Artigo

  • Angelica

    O plugin Admin Drop Down Menu WordPress Plugin by OZH é sim compatível, ele se desativa na atualização e depois pode ser ativado que pede para auto-atualizar-se.

    15/12/2008

    Responder
  • Wagner Reis

    O recomendavel também e dar uma clicada no link nos sites dos desenvolvedores dos plugins e ver se ele já suporta o 2.7! =)

    15/12/2008

    Responder
  • Rafael Marques

    Ótimas dicas como já é de costume do Fique-Rico. Atualmente tenho dois blogs, atualizei um deles para a versão 2.7. Por enquanto não tive problemas, pelo contrário, alguns pequenos bugs do 2.6 como upload de fotos voltou ao normal. Uso basicamente plugins para SEO, Performance e Sitemaps, não tive problemas.

    16/12/2008

    Responder
  • Pedro T

    Olá Paulo,
    fiz a actualização automática para a versão 2.7 e até agora não tenho tido nenhum problema. Aliás, esta nova versão está bastante mais intuitiva, e mais fácil de utilizar.
    Cumpts

    16/12/2008

    Responder
  • Rodrigo R. Neto

    Gostei muito da nova versão do WP. Ficou muito melhor mesmo.

    Tive problemas apenas com os plugins "PHP Speedy WP" e o "TinyMCE Advanced".

    Estou apenas aguardando as atualizações dos mesmos para reativá-los, pois são excelentes plugins.

    16/12/2008

    Responder
  • David

    Instalei o WP 2.7 mas está dando erro.
    Na tela de login:
    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-login.php on line 255

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-login.php on line 267

    e ao tentar logar aparece a seguinte mensagem

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-login.php on line 255

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-login.php on line 267

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-includes/pluggable.php on line 649

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-includes/pluggable.php on line 650

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-includes/pluggable.php on line 651

    Warning: Cannot modify header information - headers already sent by (output started at /home/hipero/www/wp-config.php:1) in /home/hipero/www/wp-includes/pluggable.php on line 850

    Alguém poderia me ajudar?
    Já tirei espaços, já modifiquei permissões e nada.

    Abraço!

    16/12/2008

    Responder
  • Wagner Reis

    @Rodrigo R. Neto, verifiquei aqui e o PHP Speed já saiu a versão 0.5 que tem suporte ao 2.7

    16/12/2008

    Responder
  • analistati

    Valeu pelas dias, estarei mudando para a versão 7.0 nos próximos dias, obrigado

    Abraços :D

    16/12/2008

    Responder
  • Vinicius Escano

    Opa, ótimas dicas, sorte que a minha atualização não deu problema algum, praticamente não utilizo plugins, eu fiz meu tema, então quase tudo que preciso, acabo fazendo diretamente no tema (coisa de nerd, hahahahah).
    Abraços!!!

    16/12/2008

    Responder
  • CKO

    Excelente post..eu havia feito a atualização antes de ler esse post..fiquei com um pouco de medo..mas deu tudo certo...sensacional o post..Abraços

    17/12/2008

    Responder
  • Gustavo Roberto

    Excelente artigo :)

    17/12/2008

    Responder
  • Tiago

    boas, desde que actualizei para wp 2.7, ao adicionar um post novo ele não aparece na página inicial do blog, apenas aparece nas categorias. alguém sabe como resolver?

    23/12/2008

    Responder
  • Joliveira

    Actualizei sem problemas.

    24/12/2008

    Responder
  • Diogo Oliveira

    Viva Paulo,

    Actualizem ontem o meu blog para a versão 2.7. Correu tudo bem e a maioria dos plugins continuou a funcionar correctamente, à excepção do contact form 7, o qual me bastou actualizar para tudo ficar operacional.

    Cumprimentos.

    30/12/2008

    Responder
  • Rodrigo KrZ

    Não atualizem para o Wp 2.7

    O wordpress 2.7 tem uma vulnerabilidade e tive um blog hackeado ontem

    Quando o meu dominio era acessado, era exibida uma mensagem em turco e em inglê, sobre estados unidos e iraque.

    Não instalem o wordpress 2.7!

    10/01/2009

    Responder
  • Thyago Rezier

    Ainda estou pensando em altualizar o meu para o 2.7 na verdade mês que vem vou lançar um blogger novo sobre informatica e tecnologia (trabalho nessa aréa a mais de 13 anos) e assim sim vou colocar o 2.7, já ouvir falar sobre falhas e quebras de seguranças na plataforma. Ja que irei criar um blog prefiro testar o sistema "limpinho" do que atualizar... xD

    21/01/2009

    Responder
  • João Silva

    muito bom, anda a precizar para actualizar os meus blogs

    22/01/2009

    Responder
  • DiegoLopes

    Amigo, quando uso o plugin role manager com o ozh dorp down meno alguns linkes ficam quebrados. Estes dois plugins são muito úteis, como seu blog é forte, será q vc não poderia pedir a alguém pra integrá-los não? parece ser coisa fácil. Por exemplo, se eu não dou permissão de ferramentas para alguém, o linke ferramentas fica quebrado...

    29/01/2009

    Responder

Deixe seu comentário

Seu Gravatar

Para você partcipar dessa lista tem de estar cadastrado no Twitter. Cadastre-se agora!

Rede Escolas Plus

  • Psicologia

    Artigos sobre Psicologia, Motivação e muito mais, de uma forma prática e simples que lhe permitem melhorar a sua vida pessoal e profissional.

  • Criatividade

    Melhore a sua Criatividade através de tutoriais de desenvolvimento web, webdesign, dicas de inspiração, e muito mais.

  • WordPress

    Torne seu WordPress numa verdadeira máquina com nossos artigos, templates exclusivos, plugins e tutoriais totalmente em português.

  • Freelancer

    Arrisque em sua carreira de Freelancer seguindo nossas estratégias, dicas e recomendações, e leve seu negócio ao sucesso já hoje.

  • Apostas

    Gostava de ganhar dinheiro com seus palpites sobre esportes? Siga nossos tutoriais e dicas sobre como fazer apostas esportivas.

Subscribe to our mailing list

* indicates required Primeiro Nome * Endereço de Email *